Поиск

Полнотекстовый поиск:
Где искать:
везде
только в названии
только в тексте
Выводить:
описание
слова в тексте
только заголовок

Рекомендуем ознакомиться

'Тематика курсовых работ'
заряженных частиц в электрическом и магнитном поле Модель МГД генератора Параметрические колебания Связанные маятники Случайные колебания Законы сохра...полностью>>
'Документ'
Государственное учреждение Центр занятости населения Госслужбы занятости Чувашии, именуемое в дальнейшем «Центр», в лице директора , действующего на о...полностью>>
'Документ'
  Одной из приоритетных задач реформирования системы образования становится сегодня сбережение и укрепление здоровья учащихся, формирование у них ценн...полностью>>
'Документ'
Адресные сведения в ГАР ФИАС представлены как в соответствии с муниципальным делением, так и административно-территориальным делением Российской Федер...полностью>>

Главная > Отчет

Сохрани ссылку в одной из сетей:
Информация о документе
Дата добавления:
Размер:
Доступные форматы для скачивания:

  1. Создание и печать отчетов

Одной из основных задач создания и использования баз данных является предоставление пользователям необходимой информации на основе существующих данных. В Access 2002 для этих целей предназначены формы и отчеты. Отчеты позволяют выбрать из базы данных требуемую пользователем информацию и оформить ее в виде документов, которые можно просмотреть и напечатать. Источником данных для отчета может быть таблица или запрос. Кроме данных, полученных из таблиц, в отчете могут отображаться вычисленные по исходным данным значения, например итоговые суммы.

Отчеты и формы Access имеют много общего. Однако, в отличие от форм, отчеты не предназначены для ввода и правки данных в таблицах. Они позволяют лишь просматривать и печатать данные. В отчете невозможно изменить исходные данные с помощью элементов управления, как это мож-но сделать с помощью форм. Хотя в отчетах можно использовать такие же элементы управления для указания состояния переключателей, флажков и списков.

Отчет, как и форма, может быть создан с помощью мастера. Разделы отчета подобны разделам формы и включают заголовок и примечание отчета, область данных, а также верхний и нижний колонтитулы. В примечание отчета часто помещают поля с итоговыми значениями. Элементы управления могут быть добавлены в отчет с помощью панели инструментовПанель элементов(Toolbox), идентичной той, что используется в режиме Конструктора форм. Форматирование и группировка элементов управления в отчете выполняются аналогично форматированию и группировке элементов управления в форме. Формы могут содержать подчиненные формы, а отчеты могут содержать подчиненные отчеты.

В этой главе обсуждаются следующие вопросы:

Автоматическое создание отчета по таблице или запросу

Создание отчета с помощью мастера

Преобразование отчетов Access в другие форматы

Создание и удаление элементов отчета

Изменение свойств отчета и его элементов

Создание вычисляемых полей

Форматирование отчета

Просмотр и печать отчетов

Данная глава посвящена созданию и изменению простых отчетов, не содержащих подчиненных отчетов. О создании более сложных отчетов рассказывается в гл. 10.

  1. Автоматическое создание отчета на основе таблицы или запроса

Access предлагает несколько способов создания отчетов. Наиболее простым из них является использование средств автоматического создания отчета. Автоматически создаваемый на основе таблицы или запроса отчет называется автоотчетом. Access позволяет автоматически создавать отчеты двух форматов: в столбец и ленточный.

Чтобы создать автоотчет:

На панели объектов окна База данных (Database) щелкните по ярлыку Отчеты (Reports) и нажмите кнопку Создать (New). Появится диалоговое окно Новый отчет (New Report), представленное на рис. 6.1.

Рис. 6.1. Диалоговое окно Новый отчет

В списке диалогового окна Новый отчет (New Report) выделите один из элементов: Автоотчет: в столбец (AutoReport: Columnar) или Автоотчет: ленточный (AutoReport: Tabular).

В поле со списком, находящемся в нижней части диалогового окна Новый отчет (New Report), содержатся имена всех таблиц и запросов базы данных, которые могут быть использованы в качестве источника данных для отчета. Щелкните левой кнопкой мыши по кнопке со стрелкой для открытия списка, а затем выделите в списке необходимый элемент.

Нажмите кнопку ОК.

В результате Access автоматически создаст отчет на основе выбранного источника данных, используя ленточный формат или формат в столбец. Ленточный формат располагает поля выводимых записей в строку. Формат в столбец располагает поля выводимых записей в столбец. Автоотчет, созданный с использованием любого из этих двух форматов, будет включать все поля и записи, имеющиеся в выбранном источнике данных.

Чтобы созданный отчет можно было использовать в дальнейшем, его необходимо сохранить. Для этого выберите команду Файл, Сохранить (File, Save) или нажмите кнопку Сохранить (Save) на панели инструментов. Затем, в текстовое поле появившегося диалогового окна Сохранение (Save As) введите название нового отчета (например: Мой отчет) и нажмите кнопку ОК.

Замечание

Есть еще один вариант сохранения отчета: с помощью команды меню Файл, Сохранить как (File, Save As). Этой командой отображается диалоговое окно Сохранение (Save As) (рис. 6.2). Введите имя отчета и, прежде чем нажать кнопку ОК, убедитесь, что в раскрывающемся списке Как (As) этого окна выбран элемент Отчет (Report). Выбранный элемент определяет то, как будет сохранен новый отчет, точнее, в виде какого объекта базы данных Access. Дело в том, что в новой версии Access 2002 появилась возможность сохранить отчет в виде другого объекта базы данных — страницы доступа к данным (см. гл. 12). Сделать это позволяет другой элемент раскрывающегося списка Как — элемент Страница доступа к данным (Data Access Page).

Рис. 6.2. Диалоговое окно Сохранение

  1. Создание отчета с помощью Мастера отчетов

Еще одним простым и быстрым способом создания отчетов является использование Мастера отчетов. С его помощью можно создавать отчеты (от самых простых до включающих подчиненные отчеты), содержащие поля из одной или более таблиц или запросов. Использование Мастера отчетов позволяет очень быстро познакомиться со многими основными средствами разработки отчетов, предоставляемыми Access 2002. Процесс создания отчетов, более сложных, чем позволяет мастер, описан в гл. 10.

Чтобы более наглядно представить процесс создания отчета с помощью мастера, опишем процедуру создания отчета на основе сразу нескольких таблиц: "Товары" (Products), "Поставщики" (Suppliers) и "Типы" (Categories) базы данных "Борей" (Northwind). В отчете будет представлено текущее количество товаров на складе по категориям.

Чтобы создать простой отчет:

На панели объектов окна базы данных щелкните по ярлыку Отчеты (Reports) и нажмите кнопку Создать (New). Появится диалоговое окно Новый отчет (New Report) (см. рис. 6.1).

В списке диалогового окна Новый отчет (New Report) выделите элемент Мастер отчетов (Report Wizard). В поле со списком, находящемся в нижней части диалогового окна Новый отчет (New Report), содержатся имена всех таблиц и запросов базы данных, которые могут быть использованы в качестве источника данных для отчета. Раскройте этот список и выделите в нем таблицу "Товары". Нажмите кнопку ОК. Появится первое диалоговое окно Мастера отчетов (рис. 6.3).

Рис. 6.3. Первое диалоговое окно Мастера отчетов

Прежде всего нужно определить, какие поля включить в отчет. Из таблицы "Товары" в отчете будут использоваться следующие поля: "КодТовара" (ProductID), "Марка" (ProductName), "Цена" (UnitPrice), "НаСкладе" (UnitsInStock). С помощью кнопки ">" (или дважды щелкнув по элементу списка) поочередно переместите эти поля из списка Доступные поля (Available Fields) в список Выбранные поля (Selected Fields). В отчете поля появляются слева направо, в соответствии с последовательностью их расположения в списке Выбранные поля.

Замечание

Если на каком-либо шаге создания отчета при помощи Мастера отчетов была допущена ошибка или возникла необходимость изменения каких-либо параметров, то для возвращения к предыдущему шагу нажмите кнопку Назад (Back). Кроме того, в любой момент можно нажать кнопку Отмена (Cancel) для отказа от создания отчета и возвращения к окну базы данных.

Кроме того, чтобы видеть поставщиков товара и категории, в создаваемый отчет необходимо добавить поле "Название" (CompanyName) из таблицы "Поставщики" (Suppliers) и "Категория" (CategoryName) из таблицы "Типы" (Categories). Для добавления первого недостающего поля раскройте список Таблицы и запросы (Tables/Queries) и выберите элемент Таблица: Поставщики (Table: Suppliers). Имя поставщика не должно отображаться в конце отчета. Чтобы столбец "Название" выводился сразу за столбцом "Марка", в списке Выбранные поля (Selected Fields) выделите поле "Марка", затем в списке Доступные поля (Available Fields) выделите поле "Название" и нажмите кнопку ">". Access переместит поле "Название" из списка Доступные поля (Available Fields) и вставит его в список Выбранные поля (Selected Fields) после поля "Марка", перед полем "Цена".

Аналогично добавьте в конец списка поле "Категория" из таблицы "Типы". Чтобы перейти ко второму диалоговому окну Мастера отчетов, изображенному на рис. 6.4, нажмите кнопку Далее.

Замечание

Можно таким способом добавлять в создаваемый отчет поля из разных таблиц, которые связаны между собой в схеме данных.

Рис. 6.4. Второе диалоговое окно Мастера отчетов

Во втором диалоговом окне необходимо указать, каким образом будут структурированы данные в отчете. Мастер проверяет связи между таблицами и в зависимости от выбранного представления предлагает несколько вариантов группировки записи в отчете. Чтобы осуществить группировку по товарам, выделите в списке элемент Товары (by Products).

Нажмите на кнопку Вывести дополнительные сведения (Show Me More Information) в левой части диалогового окна для отображения одного из вспомогательных диалоговых окон Мастера отчетов. Если в этом диалоговом окне нажать кнопку Показать примеры (Show Me Examples), то Access выведет дополнительные вспомогательные диалоговые окна, в которых используются "примеры из таблиц "Продажи" (Sales Reps), "Клиенты" (Customers) и "Заказы" (Orders), позволяющие продемонстрировать различные способы группировки, которые Мастер отчетов может автоматически применить к создаваемому отчету. Закройте все вспомогательные диалоговые окна и вернитесь к диалоговому окну Мастера отчетов, изображенному на рис. 6.4. Нажмите кнопку Далее (Next) для перехода к третьему диалоговому окну Мастера отчетов.

Рис. 6.5. Предупреждение Мастера отчетов

В третьем диалоговом окне Мастера отчетов необходимо определить дополнительные уровни группировки в отчете. Выделите в списке поле "Категория" (Category) и нажмите кнопку ">" (или просто дважды щелкните по этому полю в списке), чтобы установить группировку по категории товаров (рис. 6.6).

Замечание

Если потребуется отменить добавление поля группировки, нажмите кнопку "<" или дважды щелкните по названию этого поля (выделенному жирным шрифтом) в области диалогового окна с эскизом отчета.

Мастер отчетов позволяет задать интервалы значений, по которым группируются данные. Чтобы изменить их в этом же (третьем) диалоговом окне Мастера отчетов, нажмите кнопку Группировка (Grouping Options). На экране появится диалоговое окно Интервалы группировки (Grouping Intervals), изображенное на рис. 6.7. Изменяя интервал группировки, можно влиять на способ группировки данных в отчете. Для числовых полей можно задать группировку по десяткам, сотням и прочим значениям. Для текстовых полей возможна группировка по первой букве, первым трем буквам и т.д.

Рис. 6.6. Третье диалоговое окно Мастера отчетов

Рис. 6.7. Диалоговое окно Интервалы группировки

Для создаваемого отчета выберите из списка Интервалы группировки (Grouping Intervals) вариант Обычный (Normal) и нажмите кнопку ОК. Для перехода к четвертому диалоговому окну Мастера отчетов нажмите кнопку Далее (Next).

Access 2002 позволяет сортировать записи в пределах группы по значению произвольного поля, при этом сортировка проводится не более чем по четырем полям (рис. 6.8). Выберите в первом раскрывающемся списке поле "КодТовара" (ProductID). По умолчанию принят порядок сортировки по возрастанию; если вы хотите выбрать порядок сортировки по убыванию, то нажмите на кнопку справа от раскрывающегося списка. Для возврата к сортировке по возрастанию снова нажмите на эту кнопку.

Чтобы указать для столбца отчета итоговую информацию, нажмите" на кнопку Итоги (Summary Options). В появившемся диалоговом окне Итоги (Summary Options), изображенном на рис. 6.9, можно задать параметры для выбранного столбца. Выбрать можно среди всех числовых полей отчета, не являющихся счетчиками, которые Мастер отчетов перечислит в этом диалоговом окне и позволит установить для любого из них флажки Sum, Avg, Min и Мах. В зависимости от установленных флажков Мастер отчетов добавит соответствующие итоговые поля в конец отчета, вычисляющие итоговую сумму, среднее значение, минимальное или максимальное значение данного поля по всем записям. Группа переключателей Показать (Show) позволяет выбрать, следует ли в отчете указывать только итоги или необходимо выдавать полный отчет, добавляя поля с промежуточными итогами в конце каждой группы и поля с полными итогами в конце отчета. Для создаваемого отчета установите флажки Sum для поля "НаСкладе" и Avg для поля "Цена", переключатель данные и итоги (Detail and Summary) и флажок Вычислить проценты (Calculate Percent of Total for Sum), который позволяет выводить долю группы (в процентах) в общем итоге для всех групп (рис. 6.9). Для возврата к диалоговому окну Мастера отчетов нажмите кнопку ОК.

Рис. 6.8. Четвертое диалоговое окно Мастера отчетов

Нажмите кнопку Далее (Next), чтобы перейти к пятому диалоговому окну Мастера отчетов, изображенному на рис. 6.10. Мастер отчетов предложит на выбор шесть вариантов оформления сгруппированных данных (вариантов макета отчета). В левой части диалогового окна Мастера отображается эскиз выбранного макета. Выберите в группе Макет (Layout) переключатель ступенчатый (Stepped). По умолчанию Мастер отчетов устанавливает флажок Настроить ширину полей для размещения на одной странице (Adjust the field width so all fields fit on a page), что позволяет сэкономить бумагу и сделать отчет более удобным для чтения. В группе Ориентация (Orientation) можно выбрать расположение страницы отчета при печати. Широким отчетам, в которых отображается много полей в одной строке, удобно задавать ориентацию альбомная (Landscape). Для отчета же из нашего примера оставьте выбранным переключатель книжная (Portrait). Чтобы перейти к шестому диалоговому окну Мастера отчетов, нажмите кнопку Далее (Next).

Рис. 6.9. Диалоговое окно Итоги

Рис. 6.10. Пятое диалоговое окно Мастера отчетов

В шестом диалоговом окне Мастера отчетов выберите один из предложенных стилей оформления отчета. В левой части диалогового окна Мастера отображается эскиз отчета выбранного стиля (рис. 6.11). Для создаваемого отчета выберите стиль Сжатый (Compact), а затем нажмите кнопку Далее (Next) для перехода к последнему диалоговому окну Мастера отчетов.

Замечание

В шестом окне Мастера отчетов отображается список всех доступных в данный момент стилей. Кроме шести заранее определенных стандартных стилей, Access позволяет настроить любой стандартный стиль или создать свой собственный для использования при оформлении форм и отчетов, в том числе с помощью мастера. Набор вариантов оформления для отчетов можно пополнить и применить аналогично тому, как это делается для форм (см. разд. "Применение автоформата"гл. 5).

Рис. 6.11. Шестое диалоговое окно Мастера отчетов

В последнем диалоговом окне Мастера отчетов (рис. 6.12) в качестве заголовка отчета введите: Товары на складе. Мастер отчетов сохранит созданный отчет под этим же именем. Выберите переключатель Просмотреть отчет (Preview the Report) и нажмите кнопку Готово (Finish) для завершения создания отчета. Мастер отчетов создаст отчет и отобразит его в режиме Предварительного просмотра. Если при этом необходимо получить справку по работе с отчетом, предварительно установите флажок Вывести справку по работе с отчетом? (Display Help on Working with the Report?).

На рис. 6.13 изображен отчет, созданный мастером. Для просмотра всех частей отчета воспользуйтесь вертикальной и горизонтальной полосами прокрутки. Этот отчет можно использовать непосредственно в том виде, как его создал мастер, или применить его как основу для разработки более сложного отчета.

Рис. 6.12. Последнее диалоговое окно Мастера отчетов

Рис. 6.13. Отчет "Итоговый запрос предприятия", созданный Мастером отчетов

  1. Преобразование отчетов

Вы создаете базу данных, накапливаете в ней данные, редактируете и анализируете их, используя средства Access. В какой-то момент, когда результаты обработки данных готовы, вы представляете их в виде отчета Access — внешне выглядящего как обычный документ, но этот документ можно просмотреть лишь в базе данных Access, в которой он сохранен. Этот вариант не годится, когда результаты своей работы в виде отчета Access вы хотите передать кому-либо другому, кто не работает с Access или даже, возможно, вообще не имеет дела с базами данных. Самый простой вариант — напечатать отчет на принтере, и тогда формат, в котором он был создан, не будет иметь значения. Но чаще всего отчет требуется передать именно в электронном виде, например переслать по электронной почте или другим способом предоставить данные из отчета, чтобы в дальнейшем они могли быть использованы в других документах.

Для решения этой задачи Microsoft Access предоставляет целый ряд возможностей преобразования отчетов в другие форматы. Это формат документов RTF, с которым можно работать в Word и некоторых других текстовых редакторах, формат электронных таблиц Excel, страницы HTML, разнообразные текстовые форматы (файлы с расширением txt, csv, tab, asc) с возможностью сохранения содержимого отчета на выбор в кодировке Windows, MS-DOS или Unicode, специальный формат снимков отчетов (snapshot). В новой версии Access 2002 к этим форматам добавились страницы доступа к данным и XML.

В этом разделе мы расскажем о том, как просто преобразовать отчет Access в любой из этих форматов. И вы сможете кому-либо передать отчет в наиболее удобном для него виде или использовать выбранный формат, чтобы поработать с отчетом в другом приложении.

    1. Преобразование отчета в формат документов Word и Excel

Access 2002 позволяет преобразовать созданный отчет в документ Microsoft Word формата RTF. Чтобы выполнить такое преобразование:

Откройте отчет в любом режиме или просто выделите его в окне базы данных.

Выберите команду Сервис, Связи с Office, Публикация в Microsoft Word (Tools, Office Links, Publish It with MS Word).

В результате Access 2002 создаст файл формата RTF в текущем каталоге, например в папке \Мои документы (\Му Documents), по умолчанию используя в качестве имени файла название отчета, а затем откроет его в Word.

С помощью соседней команды меню Сервис, Связи с Office, Анализ в Microsoft Excel (Tools, Office Links, Analyze It with Microsoft Excel) можно преобразовать отчет в электронную таблицу Excel. При выборе этой команды автоматически создается новая рабочая книга Excel, в которую помещается рабочий лист с представлением отчета в виде электронной таблицы. В качестве имени файла XLS используется имя отчета.

Замечание

Эти команды преобразования в формат документов Word и Excel доступны также для таблиц, запросов и форм Access. Кроме того, для таблиц и запросов доступна еще команда Сервис, Связи с Office, Слияние с Microsoft Word (Tools, Office Links, Merge It with Microsoft Word). С помощью этой команды вызывается Мастер слияния, который позволяет на основе выделенной таблицы или запроса создать документ Word, связанный с этим источником данных, или связать данную таблицу или запрос с уже существующим документом Word, таким образом, что, когда данные в таблице или запросе будут изменяться, будут соответственно обновляться связанные поля в документе.

    1. Преобразование отчета в другие форматы

В Access 2002 существует средство преобразования отчетов в целый ряд других форматов. Это средство называется экспортом. Чтобы экспортировать отчет Access в какой-нибудь другой формат, выделите отчет в окне базы данных или откройте его в любом режиме, а затем выберите команду Файл, Экспорт (File, Export). Появится диалоговое окно экспорта объекта базы данных, похожее на стандартное окно сохранения файла, в котором в качестве типа сохраняемого файла можно выбрать любой формат из предлагаемого списка:

Microsoft Access (для копирования отчета в другую базу данных);

Microsoft Excel 5—7 (для преобразования отчета в формат ранних версий Excel);

Microsoft Excel 97—2002 (для преобразования отчета в формат последних версий Excel);

страницы HTML (HTML Documents) (для преобразования отчета в формат статических Web-страниц в формате HTML);

текстовые документы (Text Files) (для преобразования в один из текстовых форматов Windows или MS-DOS: TXT, CSV, TAB, ASC);

Reach Text Format (для преобразования отчета в документ Word);

снимок (Snapshot Format) (для преобразования отчета в формат статических снимков);

документы XML (XML Documents) (для преобразования отчета в формат динамических Web-страниц в формате XML).

Выбрав формат в раскрывающемся списке Тип файла (Save as type), введите в поле Имя файла (File name) имя файла, который будет создан, и нажмите кнопку Экспорт (Export). Предварительно можно установить в этом диалоговом окне флажок Автозапуск (Autostart), если вы хотите, чтобы после экспорта автоматически открылся созданный файл в приложении, в котором этот файл можно просмотреть.

Экспортировать отчет в один из перечисленных форматов можно также с помощью макроса, включающего макрокоманду OutputTo, или используя одноименный метод объекта DoCmd в процедуре VBA (о применении макросов и программировании на VBA см. гл. 11 и 13).

Вы можете также послать отчет по электронной почте в одном из форматов экспорта прямо из Access программным путем, с помощью макроса, используя макрокоманду SendObject, или с помощью процедуры VBA, используя одноименный метод объекта DoCmd. (0 преобразовании отчетов Access в различные форматы Web-страниц подробнее будет рассказано в разд. "Преобразование объектов базы данных в Web-страницы" гл. 12.)

    1. Снимки отчетов

В предыдущей версии Access 2000 появилось новое средство публикации отчетов, отличающееся от экспорта в разнообразные наиболее популярные форматы документов. Это — преобразование отчетов Access в специально разработанный для задачи их публикации формат снимков отчетов (report snapshot). Основная идея этого новшества — предоставление компактного представления отчетов Access в виде отдельных от базы данных файлов (снимков отчетов), которые можно просматривать, листать и печатать без использования Microsoft Access, с помощью специально созданного очень небольшого приложения, названного "Просмотр снимков" (Snapshot Viewer). Эта программа совершенно независима от самого Microsoft Access и может быть установлена без установки на компьютер пакета Microsoft Office. Ее дистрибутив входит в состав пакета, а также доступен через Интернет на Web-узле Microsoft: http://www.microsoft.cora . Электронную версию отчета Access в виде файла снимка отчета можно также переслать по электронной почте или распространить другим способом передачи файлов. Те пользователи, на чьих компьютерах установлена программа "Просмотр снимков", смогут просмотреть полученный в виде снимка отчет. В новой версии Access 2002 это средство сохранилось.

Для преобразования отчета Access в формат снимка требуется воспользоваться тем же, упомянутым в предыдущем разделе, средством экспорта объектов базы данных Access.

Снимок отчета — файл с расширением snp — содержит копии всех страниц отчета, включая графические и другие вложенные объекты. Чтобы на основе отчета Access создать снимок:

В окне базы данных в списке отчетов выделите нужный отчет и выберите команду Файл, Экспорт (File, Export). Появится диалоговое окно Экспорт объекта (Export Object).

В раскрывающемся списке Тип файла (Save as type) выберите элемент Снимок (Snapshot Format), в раскрывающемся списке Папка (Save in) выберите папку, в которой будет сохранен файл, а в поле Имя файла (File name) введите имя файла снимка. Нажмите кнопку Экспорт (Export).

Созданный в результате снимок отчета будет сохранен в указанной папке, после чего он будет открыт в автоматически запущенном (если ранее не было запущено) приложении "Просмотр снимков" (рис. 6.14).

Замечание

Если программа "Просмотр снимков" на вашем компьютере не была установлена (она не устанавливается со стандартной конфигурацией Access), то в этот момент будет произведена автоматическая попытка установить ее. Поэтому, возможно, вы получите сообщение с требованием вставить в дисковод дистрибутивный диск Microsoft Office.

Рис. 6.14. Снимок отчета "Каталог" из демонстрационной базы данных

В нижней части окна приложения "Просмотр снимков" содержится панель навигации, которая позволяет листать страницы отчета при просмотре. Крайняя справа кнопка на этой панели позволяет выполнить печать отчета. Щелкнув правой кнопкой мыши по области отчета, вы откроете контекстное меню, которое включает команды, дублирующие функции кнопок панели навигации, и команду Масштаб (Zoom), с помощью которой вы сможете регулировать масштаб отображения страниц отчета в окне программы Просмотра снимков. Это приложение позволяет одновременно просматривать несколько снимков отчета. Переключаться между снимками и управлять расположением их окон внутри приложения можно с помощью команд меню Окно (Window). Кроме просмотра и печати снимков программа "Просмотр снимков" позволяет также пересылать их по электронной почте. Для этого нужно выбрать команду меню Файл, Отправить (File, Send). Тогда появится окно сообщения Microsoft Outlook, в которое автоматически попадет снимок отчета в виде вложенного файла (рис. 6.15). Останется заполнить необходимые поля и отправить сообщение с помощью кнопки Отправить (Send). Получателю сообщения достаточно дважды щелкнуть мышью по значку вложенного файла, чтобы запустить программу "Просмотр снимков" и открыть в ней полученный снимок.

Рис. 6.15. Отправка снимка отчета по электронной почте

Создав файл снимка отчета, вы можете сразу поместить его в папку на Web-узле и, установив ссылки на него на Web-страницах, предоставить доступ к этому снимку отчета всем пользователям Интернета или внутренней сети итранет с помощью программы просмотра Internet Explorer.

Для просмотра снимков отчетов можно также использовать элемент ActiveX — файл Snapview.ocx, который входит в состав дистрибутива пакета Microsoft Office 2002. Например, чтобы использовать этот ActiveX в качестве элемента управления в каком-либо объекте представления данных в Access (форме, отчете, странице доступа к данным), требуется включить ссылку на него. Для этого в редакторе VBA выберите команду Сервис, Ссылки (Tools, References) и в появившемся диалоговом окне установите флажок напротив элемента списка Snapshot Viewer Control (Элемент Просмотр снимков).

  1. Режимы работы с отчетами

Работа с отчетами Access 2002 может происходить в трех режимах: в режиме Просмотра образца, в режиме Предварительного просмотра и в режиме Конструктора. Переключиться из одного режима в другой можно либо с помощью команды Образец (Layout Preview), Предварительный просмотр (Print Preview) или Конструктор (Design View) в меню Вид (View) в любом режиме работы с отчетом, либо с помощью кнопки Вид (View) панели инструментов Конструктор отчетов (Report Design) в режиме Конструктора.

Режим Предварительного просмотра предназначен для просмотра отчета в Access в том виде, как он будет выведен на печать. Отчет, открытый в режиме Предварительного просмотра, можно просмотреть в увеличенном или уменьшенном масштабе, отобразить на экране одновременно одну или несколько страниц, а также напечатать, предварительно определив параметры страницы. По умолчанию из окна базы данных (при двойном щелчке по отчету или нажатии кнопки Открыть (Preview) в окне базы данных) отчет открывается именно в этом режиме. Если отчет был открыт в другом режиме, то для перехода в режим Предварительного просмотра выберите команду Вид, Предварительный просмотр (View, Print Preview) или нажмите на стрелку, расположенную справа от кнопки Вид (View) панели инструментов Конструктор отчетов (Report Design) и в открывшемся списке выберите элемент Предварительный просмотр (Print Preview).

Рис. 6.16. Отчет "Итоговый запрос предприятия" в режиме Конструктора

Режим Просмотра образца является удобным средством проверки внешнего вида и структуры (макета) создаваемого отчета. В этом режиме в окно просмотра выводятся только те данные, которые необходимы для заполнения каждого из элементов макета отчета. Для просмотра всех данных, выводящихся в отчете, следует использовать режим Предварительного просмотра. Чтобы перейти в режим Просмотра образца, выберите команду Вид, Образец (View, Layout Preview) или нажмите на стрелку, расположенную справа от кнопки Вид (View) панели инструментов Конструктор отчетов (Report Design) и в открывшемся списке выберите элемент Образец (Layout Preview).

В режиме Конструктора можно разрабатывать отчеты, модифицировать их структуру, изменять внешний вид, добавлять и удалять поля. Этим режимом обычно пользуются разработчики отчетов Access. Чтобы перейти в режим Конструктора, выберите команду Вид, Конструктор (View, Design View) или нажмите на стрелку, расположенную справа от кнопки Вид (View) панели инструментов Конструктор отчетов (Report Design) и в открывшемся списке выберите элемент Конструктор (Design View). На рис. 6.16 показан открытый в режиме Конструктора отчет, создание которого описано в разд. "Создание отчета с помощью Мастера отчетов"этой главы.

Замечание

Создать новый отчет можно "с нуля", начиная его разработку сразу в режиме Конструктора, не пользуясь средствами автоматического создания отчетов и Мастером отчетов Access. Для этого достаточно дважды щелкнуть по ярлыку Создание отчета в режиме конструктора (Create report in Design view) над списком отчетов в окне базы данных.

  1. Режим Предварительного просмотра

Если в окне База данных (Database) дважды щелкнуть левой кнопкой мыши по имени существующего отчета, то на экране появится отчет в режиме Предварительного просмотра. На рис. 6.17 изображена панель инструментов Предварительный просмотр (Print Preview), а в табл. 6.1 перечислены кнопки панели инструментов и соответствующие им команды меню в режиме Предварительного просмотра.

Рис. 6.17. Панель инструментов Предварительный просмотр

Кнопка

Команда меню

Описание

Вид (View)

Вид, Конструктор (View, Design View) Вид, Предварительный просмотр (View, Print Preview) Вид, Образец (View, Layout Preview)

Переключение между тремя режимами работы с отчетом

Печать (факс) (Print (Fax))

He предусмотрена

Печать отчета или отправка его по факсу без отображения диалогового окна Печать (Print). Печать отчета выполняется с использованием текущих параметров принтера

Масштаб (Zoom)

Вид, Масштаб, 100% (View, Zoom, Zoom 100%), Вид, Масштаб, Вписать в окно (View, Zoom, Fit То Window)

Обеспечивает переключение между полностраничным режимом просмотра и режимом просмотра в натуральную величину. Щелчок левой кнопкой мыши, если ее указатель принял форму увеличительного стекла, приведет к тем же результатам

Одна страница (One Page)

Вид, Число страниц, Одна страница (View, Pages, One Page)

Отображает на экране одну страницу

Две страницы (Two Pages)

Вид, Число страниц, Две страницы (View, Pages, Two Pages)

Отображает на экране две страницы

Несколько страниц (Multiple Pages)

Вид, Число страниц, Четыре страницы (View, Pages, Four Pages), или Восемь страниц (Eight Pages), или Двен-надцать страниц (Twelve Pages)

Отображает на экране несколько страниц

Список Масштаб (Zoom)

Вид, Масштаб (View, Zoom)

Изменяет масштаб изображения от 10 до 1000% либо обеспечивает масштабирование отчета по размеру окна

Закрыть (Close)

Файл, Предварительный просмотр (File, Print Preview)

Закрывает окно предварительного просмотра и обеспечивает возврат в режим Конструктора отчета или в окно База данных (Database)

Установка (Setup)

Файл, Параметры страницы (File, Page Setup)

Отображение диалогового окна Параметры страницы (Page Setup)

Связи с Office (OfficeLinks)

Сервис, Связи с Office (Tools, Office Links)

Выводит раскрывающийся список команд для связи с программами Microsoft Office: Публикация в Microsoft Word (Publish It with Microsoft Word) и Анализ в Microsoft Excel (Analyze It with Microsoft Excel). (Команда Слияние с Microsoft Word (Merge It with Microsoft Word) для отчетов не доступна)

Окно базы данных (Database Window)

Окно, 1 (Window, 1)

Открывает окно базы данных

Справка по Microsoft Access (Microsoft Access Help)

Справка, Справка по Microsoft Access (Help, Microsoft Access Help)

Вызов помощника и получение справки Access 2002

Новый объект (New Object)

Нет

Создает новый объект. Щелкните по стрелке справа от этой кнопки, появится раскрывающийся список объектов, которые можно создать

Таблица 6.1. Панель инструментов Предварительный просмотр



Похожие документы:

  1. К 1927 г позиции Амторга (то есть, фактически, ссср) на американском рынке выглядели двояко. Советский экспорт в США составлял всего 0,3% импорта Соединённых

    Документ
    ... таблицы. 4* Пулемет «Максим», название первого в мире боеспособного автоматического оружия — станкового пулемета, созданного ... главами наркоматов и отдельных их органов по важнейшим вопросам обороны; а также путем создания ... Обсуждались следующие вопросы: ...
  2. Увсего отдела продаж слетает программа, все начинют визжать и дергать it: работы мол много, чини. Каждые 20 минут спрашивают ну что долго, долго еще?! Вэто время каждый сидит, кто фотки смотрит, кто в косынку рубится

    Программа
    ... Сидоровых клиент "Создание Извне" ... отчет в виде таблицы, ... это обсуждали, попутно ... по Eхchange. Глава ... втыкать, или, по крайней ... запросы со следующих IP ... Вопросов нет. На следующий день пришел наш главный по ... : здоровенный автоматический погрузчик, ...
  3. «Прикладная Юридическая Психология»

    Документ
    ... обсуждаются вопросы ... Таблица 5.1. Управленческиероли (по ... или подчиненных, тонегативная установка к личности автоматически ... Следует включать в системуподготовки сотрудников достаточное число занятий по вопросам ... по воссоздающей визуализации,т.е. по созданию ...
  4. Российской академии образования, чьи книги издавались и переиздавались не только на русском, но и на многих иностранных языках. Isbn 5-86225-812-4

    Документ
    ... по типу механической детерминации (по типу рефлекса как автоматического ... соответственно запросам новой ... прежних созданных ... обсуждая вопрос, какой науке изучать чисто субъективные зрительные явления - психологии или ... Итак, таблицу следует рассматривать ...
  5. В. Е. Каган Воспитателю о сексологии

    Документ
    ... публикацией «Отчетов Кинзи» ... показано в таблице. В итоге ... автоматически идет по ... лет. Вэто время у ... отвечать реальным запросам детского развития ... следующий вопрос. ... или менее единому их пониманию. В предыдущей главе мы обсуждали ... * Создание системы полового ...

Другие похожие документы..